Hi,
Just bought CJT Virtual crowd so see if I could learn a bit as to how it works.
Read the install and uploaded .zip file and so far so good.
However, syntax errors and inconsistencies started to appear.
Some questions:
1) In css files the <style> </style> generates syntax error. Same for JS config. (I understand <style> </style> in HTML, but css and js?)
2) Don’t like !important
3) float and inline don’t mix
There are more, but please check it out yourself and perhaps update 🙂
//Thor

Dear Sir/Madam,

I purchased the CJT and able to login the site but I cannot find the link to download it back, please advise where I can download the paid version.

Best regards,

Kelvin.

Hi,

I can see how to rollback to a revision but can’t work out how to:

1] delete a particular revision
2] delete all revisions (except current) – ie purge old

P.S If I do it through file-manager I assume I have left a database record behind – yes?

Can you help please. CJT plus.

Cheers

Kat

We are using WordPress version 4.9.8.
We have deactivated and deleted the older CJT CORE and CJT PLUS plugins from our development site. Then we uploaded and activated the CJT FREE 8.4.1.
We did not see the existing code blocks after this. Instead we see only the following (with the errors displayed from Chrome’s Console in red below):
screenshot1

Then we added and activated CJT Plus 8.4.
This is what we found after the update to CJT Plus 8.4:
Screenshot 2
Screenshot3

We need to update to this newest version of CJT, but we cannot with these issues. Let us know if we can help with correcting these errors.

As a follow up, once we deactivate and delete the CJT FREE 8.4.1 and CJT PLUS 8.4, and revert back to CJT Core 9.0.1 and CJT Plus 2.0, and activate both, we still cannot see the existing code blocks. If we deactivate CJT Plus 2.0 we can see the code blocks though.

Here is a screen shot (with Google Chrome Console errors showing) when CJT Core 9.0.1 and CJT Plus 2.0 are activated:
Screenshot4

Thank you!

Just installed and activated the CJT Plus and received a jQuery Uncaught ReferenceError: jQuery is not defined.
http://uploads.aragato-server.net/screenshots/20180821dfd7956434.png

When I deactive CJT PLUS the error is gone.

WordPress Standard Theme, no other plugins activated.

Hello,
I’m getting an update notification for Toolbox plus but it’s going from 1.1.1 to 8.4. This isn’t right, right? See this screenshot: https://www.sugarsync.com/pf/D646892_07204924_9140753

Why is it trying to jump from 1.1.1 to 8.4? It also says “Automatic update is unavailable for this plugin.”
Please advise. Thank you.

I have a code segment with language set to JS.

Within the code block is an extra long string whose length exceeds the editor window. To view the whole string you need to use the horizontal scroll bar a lot.

The editor is not resolving cursor positioning within this line of text; on click the I-beam is misaligned over a character (not between) or when it appears to be correctly sitting between characters for editing to commence I find the wrong characters deleted (if backspace or delete key used) or new text inserted being placed in wrong position.

Basically you cannot trust or use the editor for this line of text as any edits are incorrect.

The line of code is:

var rX= /(^180[ |-]{0,1}2[ |-]{0,1}[0-9]{1}[ |-]{0,1}[0-9]{2}$)|(^1800|1300[ |-]{0,1}[0-9]{3}[ |-]{0,1}[0-9]{3}$)|(^1800|1300[ |-]{0,1}[0-9]{2}[ |-]{0,1}[0-9]{2}[ |-]{0,1}[0-9]{2}$)|(^13[ |-]{0,1}[0-9]{2}[ |-]{0,1}[0-9]{2}$)|(^[1-9]{1}[0-9]{3}[ |-]{0,1}[0-9]{4}$)|(^\({0,1}02\){0,1}[ |-]{0,1}[1-9]{1}[0-9]{3}[ |-]{0,1}[0-9]{4}$)|(^\({0,1}0[3|7|8]\){0,1}[ |-]{0,1}[0-9]{4}[ |-]{0,1}[0-9]{4}$)|(^0[4|5][0-9]{2}[ |-]{0,1}[0-9]{3}[ |-]{0,1}[0-9]{3}$)|(^0[4|5][0-9]{2}[ |-]{0,1}[0-9]{2}[ |-]{0,1}[0-9]{2}[ |-]{0,1}[0-9]{2}$)|(^\+{0,1}61[ |-]{0,1}[4|5][ |-]{0,1}[0-9]{4}[ |-]{0,1}[0-9]{4}$)|(^\+{0,1}61[ |-]{0,1}[4|5][0-9]{2}[ |-]{0,1}[0-9]{3}[ |-]{0,1}[0-9]{3}$)|(^\+61\s*[45]\s*(?:[0-9]\s*){8}$)|(^\+{0,1}61[ |-]{0,1}[2|3|7|8][ |-]{0,1}[1-9]{1}[0-9]{3}[ |-]{0,1}[0-9]{4}$)|(^\+[1-9](?: [0-9]?){5,13}[0-9]$)|(^\+[1-9](?:[0-9] ?){5,13}[0-9]$)/g;

I dare you to try and change the {5,13} to {5,14} in the second last pattern group;
OR
Remove the space preceding ‘?){5’
AND
insert a space between ‘?:’ and ‘[0-9]’ in the last pattern group.

These simple edits deliver unexpected and unwanted results; even with careful mouse clicking to identify insertion and deletion points.

How do I remove/stop your CJT plugin notices from showing on dashboard for non Administrators?
These notices are intrusive and irrelevant for roles not “Web development’ or “Administrator”.

Hi there,
Please forgive my extreme ignorance in advance, but I have just purchased a “forever license” for CSS & JavaScript Toolbox PLUS.
Currently, we have a staging site and a live site.
Our developer originally installed
CJT Core and CJT Plus (which I can see have different license keys)
However, the developer did not renew the license and we were continually getting error messages on the Dashboard and when checking the license keys in the settings it said the license key was not valid.
I tried to deactivate and reset the developers key and input the license key and activate the one just purchased for CJT Plus but it says the key is invalid! What am I doing wrong?
Also, do I need another key for the CJT Core part?
Please, can you help? I don’t want to lose the code that our developer already has created, but do want to update the license to a valid key.

Hi,

we use a Google Tag Manager script that has to be placed directly after the <body> tag. Currently we use the CSS & JavaScript Toolbox PLUS version. I’m unsure if this can be done in that plug in. Is it possible to do in Easy Code Manager?

Cheers
Johan

Hi there

I just saw in a website that it is running Plus 1.0 and that 1.1.1 is available and that auto-updates are not available.
I tried looking everywhere and https://css-javascript-toolbox.com/purchase-history/ to find the new version to download, but I can’t find it.

Help please
Thanks
Mark

My wp-config.php (multi site) preferences sets ‘WP_CONTENT_DIR’ like
define(‘WP_CONTENT_DIR’, ABSPATH . ‘BIND-OTHER-DIR’);

Theese are my NGINX error logs.

2017/05/26 12:58:32 [error] 7280#0: *665 open() “/PATHTO/DocumentRoot/BIND-OTHER-DIR/plugins/cjte-developer/extensions/cjte-import-export-tool/views/tools/index/public/css/index.css” failed (2: No such file or directory), client: 000.000.000.00, server: mydomain.com, request: “GET /BIND-OTHER-DIR/plugins/cjte-developer/extensions/cjte-import-export-tool/views/tools/index/public/css/index.css?ver=4.7.5 HTTP/1.1”, host: “mydomain.com”, referrer: “https://mydomain.com/wp-admin/admin.php?page=cjtoolbox-tools”

2017/05/26 12:59:06 [error] 7281#0: *716 open() “/PATHTO/DocumentRoot/BIND-OTHER-DIR/plugins/PATHTO/DocumentRoot/wp-content/plugins/css-javascript-toolbox-plus/Media/Stylesheet/jQueryTheme/jquery-ui.min.css” failed (2: No such file or directory), client: 000.000.000.00, server: mydomain.com, request: “GET /BIND-OTHER-DIR/plugins/PATHTO/DocumentRoot/wp-content/plugins/css-javascript-toolbox-plus/Media/Stylesheet/jQueryTheme/jquery-ui.min.css HTTP/1.1”, host: “mydomain.com”, referrer: “https://mydomain.com/wp-admin/network/admin.php?page=cjtms-dashboard”

2017/05/26 12:59:12 [error] 7281#0: *737 open() “/PATHTO/DocumentRoot/BIND-OTHER-DIR/plugins/PATHTO/DocumentRoot/wp-content/plugins/css-javascript-toolbox-plus/Media/JavaScript/AjaxServer.js” failed (2: No such file or directory), client: 000.000.000.00, server: mydomain.com, request: “GET /BIND-OTHER-DIR/plugins/PATHTO/DocumentRoot/wp-content/plugins/css-javascript-toolbox-plus/Media/JavaScript/AjaxServer.js HTTP/1.1”, host: “mydomain.com”, referrer: “https://mydomain.com/wp-admin/admin-ajax.php?action=cjtplus-ajax-access-point&cjtpls-view=MSDashboardPanel&cjtpls-action=Index&cjtpls-template=UsersList&”

2017/05/26 13:04:06 [error] 7280#0: *1019 open() “/PATHTO/DocumentRoot/BIND-OTHER-DIR/plugins/PATHTO/DocumentRoot/wp-content/plugins/css-javascript-toolbox-plus/Media/JavaScript/AjaxServer.js” failed (2: No such file or directory), client: 000.000.000.00, server: mydomain.com, request: “GET /BIND-OTHER-DIR/plugins/PATHTO/DocumentRoot/wp-content/plugins/css-javascript-toolbox-plus/Media/JavaScript/AjaxServer.js HTTP/1.1”, host: “mydomain.com”, referrer: “https://mydomain.com/wp-admin/admin-ajax.php?action=cjtplus-ajax-access-point&cjtpls-view=MSDashboardPanel&cjtpls-action=Index&cjtpls-template=SitesList&”

…Its seems double ‘WP_CONTENT_DIR’ path.

When I disable CJT PLUS, just work CJT only.
All work when I off “define(‘WP_CONTENT_DIR’, ABSPATH . ‘BIND-OTHER-DIR’);”.

I found hard coded ‘wp-content’ some php files in CJT and CJT PLUS…

Will you be improved update?

Dear Damian Baker,

I frequently found below SQL error from my error.log, what is the problem? How can I fix it?

SELECT blocks.id,blocks.name,blocks.pinPoint,blocks.location,blocks.links,blocks.expressions,(blocks.pinPoint & 17) blocksGroup FROMwp_cjtoolbox_blocks` blocks
LEFT JOIN wp_cjtoolbox_block_pins pins
ON blocks.id = pins.blockId WHERE (((backupId IS NULL) AND (state = ‘active’)) AND
((blocks.pinPoint & 17) OR ((blocks.pinPoint & 32) AND (pins.pin = ‘pages’) AND (pins.value IN ())))); made by require(‘wp-blog-header.php’), require_once(‘wp-includes/template-loader.php’), do_action(‘template_redirect’), WP_Hook->do_action, WP_Hook->apply_filters, call_user_func_array, CJTBlocksCouplingController->initCoupling, CJTBlocksCouplingController->getBlocks, CJTCouplingModel->getPinsBlocks, CJTPinsBlockSQLView->exec, CJTMYSQLQueueDriver->select`

Hi,
Do you support multisite?
I could really need a AUX setting saying “All Sites – Entire website”.
Is there a way to do this?

Kind regards
Sjur Sørskår

all my script have the same problem when I click page to be able to add it to a page I can only acces 46 pageof /152

Hello

We are getting this error message on our website on the WordPress Updates page:

CJT Extension update errorAPI Service Exception<br /> Details: <br /><br /> License not found for the specified identifer/licenseKey:0

We have tried re-entering the CORE licence key and the error message still remains. There does not seem to be anywhere to enter the PLUS licence key.

Best

Simon

Hi, I want to use this external script
http://code.jquery.com/jquery-1.7.1.js

so I go to Panel -> External Script then I put that link there.
Then I click “Link External” button, but it did not do anything.
How do I know if the script has been loaded?
Because my code that is using that script is still not working.

And if I want to remove this external script, how do I do that?

Thanks,
Donny

Running a fresh install WordPress 4.7.
Contact form 7 and Infuse Content Blocks are the only other plugins installed.
After uploading and installing the plugin, it does not show up in the left column toolbar.

Thanks,
David

Hi Damian,
For some reason this plugin does not work with the SSL Certificate. How do I get the plugin to work with the SSL certificate. When the SSL Certificate in installed it takes the content off of the site that this plugin puts on there. Please get back to me as soon as possible because we are selling things on our site and it needs to be secure.

Thank you Damian,

David Glatzl

I just went to my WordPress updates page and saw that I got a CJT update error, even though I have a license enabled fine. See below:

Error 1

Error 2

Hi there, I appreciate the new update. I was able to get it installed. At first, it didn’t work, but I remembered the email about clearing the cache. After I did that, it worked great.

But that’s not what I’m writing about — I just had a quick question/suggestion about usage of space. I don’t understand why the full width of the titles of the code blocks isn’t used to show as much of the code block title as possible. No matter the width of the browser window, it always shows the code block title in a very short box. Could you please use the full available space to show as much of the code block as possible?

Thanks!

After the recent update of CJT i started getting the following db errors. the update was for CJT only. i have CJT plus so don’t know if it is the cause. errors from my debug panel shown below.

http://prntscr.com/cyrt79

I noticed that pages and posts that are marked private do not show up in the page and post list. How could I add code blocks to header/footer of these pages?

I get this error message when I try to activate my license.
I have version 7.1

If I update the plugin to 8.2 first, then I no longer have a Settings submenu – there is no place to enter my license key field.

Do I need to download a new version of Plus?

Thanks!
Steve

I am having a strange problem. I have around 1800 lines of code in a code block and it is crashing my page (ie the sidebar disappears). but if i split the code up and make it into 2 blocks it works. Is there a linecount limit for a code block?

Hello, is it possible to insert both PHP and JS on a post using the CJT block on the post admin page?

I ask as I have to add PHP and JS code to every product on our Woocomerce powered store and each piece of code needs to have the post ID placed in it. It is easier to add the code directly to a post otherwise I will need to create 200+ entries in the CJT admin area.

Thanks

Simon

Hi there

I’m trying to export code blocks from riscura.com/brightafrica but I’m getting no response from the plugin.
On Chrome – the button greys out, but no message or response.
On IE I get a pop up that says “Unhandled error…” when I try to view the error details, I get a blank screen.

Please advise urgently.

Running WP 4.4.2 new install. Utilizing Photology theme and I have tried other themes. I receive the following error when trying to activate CJT.

Warning: require_once(__DIR__/composer/autoload_real.php) [function.require-once]: failed to open stream: No such file or directory in /home/content/36/8791336/html/damionlloyd-beta/wp-content/plugins/css-javascript-toolbox/vendor/autoload.php on line 5

Fatal error: require_once() [function.require]: Failed opening required ‘__DIR__/composer/autoload_real.php’ (include_path=’.:/usr/local/php5/lib/php’) in /home/content/36/8791336/html/damionlloyd-beta/wp-content/plugins/css-javascript-toolbox/vendor/autoload.php on line 5

I have disabled every plugin, switched the theme and still get the fatal error.

Please help
Lucein

Hi, I’m new to CJT and strangely enough, I’m stuck at the beginning on the Permissions tab screen. I see nothing in the documentation about this screen, so I’m asking here.

The page is split in half (one is Sites, the other is Users). Both have an empty text area and an Allow List checkbox. How do I use this screen? When I click the Sites List link, a popup allows me to search, but I cannot seem to get it to locate any of my sites (this is a multisite installation BTW).

What am I doing wrong, and why isn’t this documented anywhere?

Greetings Damian!

After doing a fresh install of WP 4.3.1, CJTe Toolbox 8.1 and first without, then adding CJTe PLUS 1.1.1, I am unable to save Code Blocks on localhost running Mamp/Mamp PRO on Mac OS X (Yosemite). While I didn’t see it, is there some special config that needs to be set to save?

Checked permissions – everything else is fine.

Love CJTe and understand the need to monetize your efforts in order to provide ongoing support, and innovate on future releases.

Question – we purchased a Developer License (CJTe Developer). What does this mean in regards to the next release where you will be removing features from CSS & JavaScript Toolbox Free?

We appreciate providing some clarity.

HI we are using a shopping cart called Ecommerce Templates which requires us to add .php files into WP’s root directory.

For example cart.php, products.php, etc…

Each of these files does include the WP header but when applying “Entire Website” to a CSS/JS block in the toolbox, it never seems to get loaded on these pages.

We’ve also tried the custom urls like domain.com* with no luck either.

I was just curious if theres a known or recommended way to handle additional files in WP root.

I would of thought it would work with no problem since they are including the WP header but for whatever reason its just not loading our css/js toolbox blocks.

Heres examples of where the block loads vs doesnt on our site:

Does load: http://fugnettiimages.com/the-artist/
Doe Not load: http://fugnettiimages.com/products.php

If you look at the source code on each page you’ll see “<!– Block (1) START–>” only on the 1st url.

If theres any additional info I can supply to help, please just let me know.

Thanks!

Clint

I have several sites running CJT and CJTe developer without any issues. But all of sudden I have notices errors cropping up in the log files and frontend errors displaying in the admin.

code seems to be loading in the frontend pages correctly, but now I can not edit or add anything new to CJT.

CJT Version 8.0.3
CJTe Version 0.6

Below are some of the errors that I am seeing the log files:

# Site 1 —————————————————————————————————-
WordPress database error You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘)))))’ at line 4 for query SELECT blocks.id,blocks.name,blocks.pinPoint,blocks.location,blocks.links,blocks.expressions,(blocks.pinPoint & 4353) blocksGroup FROM wp_cjtoolbox_blocks blocks
LEFT JOIN wp_cjtoolbox_block_pins pins
ON blocks.id = pins.blockId WHERE (((backupId IS NULL) AND (state = ‘active’)) AND
((blocks.pinPoint & 4353) OR ((blocks.pinPoint & 512) AND (pins.pin = ‘posts’) AND (pins.value IN ())))); made by require(‘wp-blog-header.php’), require_once(‘wp-includes/template-loader.php’), do_action(‘template_redirect’), call_user_func_array, CJTBlocksCouplingController->initCoupling, CJTBlocksCouplingController->getBlocks, CJTCouplingModel->getPinsBlocks, CJTPinsBlockSQLView->exec, CJTMYSQLQueueDriver->select

# Site 2 —————————————————————————————————–
WP_Error as array in /web/content/wp-content/plugins/css-javascript-toolbox/framework/wordpress/feed.php on line 54
WP_Error as array in /web/content/wp-content/plugins/css-javascript-toolbox/framework/wordpress/feed.php on line 54

Admin errors displaying

# Site 1 —————————————————————————————————–
1. When I open CJT and try to add a new block, I receive the following:

403 Forbidden Error Page
If you arrived here due to a search or clicking on a link click your Browser’s back button to return to the previous page. Thank you.

this error has shown whenever trying to access different pages or aspect of CJT.

2. Trying to open an existing block, shows the loading …. forever

I look forward to your reply.

Doug

Hi Damian,

Pressing EXPORT does nothing. The EXPORT button becomes gray for a moment and that’s all.
Plugin version: 8.0.3 + CJTe Developer 0.6 activated.
WP: 4.2.2.

Could you help me?

Kind regards.
Sylwia.

It any from support can check sitiation on my account to see why is pending and way I have not free access to other extension like Editor Theme ect. ?

Maybe is silly question but I happy use so fast I can this CJT tools on my pages

pls answer

Sebastian

Hi,

I’ve got a huge problem with CJTe Developer which renders it pretty much unusable and forces me to revert to the free version.

Upon installing CJTe Developer the CSS & Javascript Toolbox page which worked flawlessly with the free version turns blank.

The code blocks are still active on the website, but can’t be edited any longer, because the editor boxes all disappear…

Please provide a fix for this.

Best Regards,

Finn

Hello,
When the CSS & JavaScript Toolbox plugin is enabled windows dashboard are blocked, some are not displayed and “Screen Options” does not work.
If I deactivates the plugin everything is normal
Best Regards

Hello,
I am new to WP, but the CSS & JavaScript Toolbox came to save me. 🙂
I’m almost getting use it 100%, only that I have a little problem. When I create my Box Styles with CSS and apply it on a particular page he takes not completely my styles, it keeps some styles of my style used in the case is Twenty Twelve, is there any way in my CSS code I reset to WP recognize my entire code?

Many Thanks,
Fábio

Greetings. AWESOME plugin! Thank you for creating, and sharing it. We have purchased a DEV license, and are actively using CJTe.

After creating several Code Blocks, I attempted to Export them using the built-in Export tool. Upon clicking the Export button, the button greys out, then nothing happens due to a 500 Internal Server error (likely a permissions error on the file in question) which can be seen in the screenshot at:

https://www.dropbox.com/s/rtd7d63e1h8r6t2/Screenshot%202015-01-27%2015.10.19.png?dl=0

As we plan on creating lots of Code Blocks, your guidance in resolving this issue would be appreciated.

I have found the auxiliary tab, selected the “Website Backend” checkbox, and then selected CSS. I have written up some custom style to change some styling in the backend of WordPress, however the styles are not applied, instead they are printed out in the header in the backend.

Is there an additional step that I have obviously missed?

Dear Damian,

I tried to add below script for specific page using CJT, I got the error, not sure whether it was not recommended to load such script using CJT, please advise.

<script>
$(document).ready(function () {
$(‘#activity-form’).load(“/form/”);
});
</script>

You can have a look to the error from http://screencloud.net/v/DQkf

Best regards,

Kelvin.

Dear Damian,

I have two pages with same title but different URL, I changed one of them the title, but the list of page is still keeping the two pages with same title. How can I refresh the list?

Best regards,

Kelvin.

Dear Damian,

I have several pages with the URI http://www.xxx.com/personnel/xxx, how can I apply the custom CSS and Javascript to those pages instead of select one by one to each pages?

Best regards,

Kelvin.

Hi
I have a supplementary question to your answer. All specific information I sent you by e-mail.

How must the assignment expressions be to apply a code to a category and another code to all posts in this category, when the default permalink structure has been changed?

Thank you very much for your answer.

—-
Hi
We have very good experience with CJT free version. Probably we will buy PRO, but first I have one question: there are …
category A, all posts of category A
category B, all posts of category B

I need now one code for all posts of category A, but a different one for category A. The same for category B: one single code for category B, and another code for posts of category B.

Is this possible with the PRO version?

—–
Your answer was:
Thanks for the positive feedback.
We’re very happy hearing that.

Yes this can be done by using Assignment Expressions From Code-Block assignment panel “Advanced Tab”.

The following expression is used to apply Code Block to Category A

^http\:\/\/WORDPRSS-SITE-DOMAIN\/category\/a\??$

The following expression is used to apply code Block to posts inside Category A

^http\:\/\/WORDPRSS-SITE-DOMAIN\/a.+

Create two blocks for the expressions above
Go to Advanced Tab, click on Expressions Item
Copy the lines above for each Code Block you created in #1

You need to replace WORDPRESS-SITE-DOMAIN by your site domain name, if you couldn’t get it works because you’re changed WordPress default permalink structure, please send us Category A URL and any post URL for any post laying under A Category.

Hope that helps.

Regards,
AHMeD

Hi,

I really love your plugin and I’m using it on many of my websites.

However, I find that the support for WooCommerce (or other custom post types) needs improvement: In the tab “Custom Posts” you can select single products, but unfortunately you can’t select all products at once and you can’t select product categories at all.

Please consider this for future version as it would saves a lot of time for WooCommerce users.

Best regards,

Finn

Is there a place in Pro version to add the license key?

Dear Sir/Madam,

I have script to check whether a user has already liked a facebook, how I can apply this to a WordPress page? I want to request the user to like my facebook before I show up the WordPress page with a form? Can I do that using CJT? For example I have page using shortcode [form form-id xx] to show form.

Best regards,

Kelvin.

Some time ago i baught the Dev version. Im working currently on a new site. So i downloaded the version from my license page, installed through the plugin installer, used the setup option, after the setup option i have to use the setup option again to activate my license which works. No problems there. Except now i update my plugin to 7.1.1 and after that the plugin says its the free version and not the dev version.. and i don’t want that off course..in the buying descriptions says the dev version is for all updates..

so i hope there is a solution for this?

Thanks in advanced,

greets Stephen

Is there a simple way to hide the CJT icon in TinyMCE editor? I don’t want end user to see this function.

Thanks,
Darren

Hi Damian,

To anybody reading this post: you modify SQL database at your own risk. Please be cautious.

THE PROBLEM (CJT v. 7.1, WP 3.9.x)
When migrating or restoring from backup a WordPress database there exist the duplicate keys problem with the following CJT tables: ‘wp_cjtoolbox_blocks’ and ‘wp_cjtoolbox_templates’.

THE SOLUTION
Before importing WP database to a new location I have made two simple modifications.
1. After SQL command
CREATE TABLE ‘wp_cjtoolbox_blocks’
I change next SQL command
UNIQUE KEY ‘name’
to
KEY ‘name’
2. After SQL command
CREATE TABLE ‘wp_cjtoolbox_templates’
I change next SQL command
UNIQUE KEY ‘guid’
to
KEY ‘guid’

Et voila! The duplicate keys errors have gone away.
So far so good. But there is still another problem.

THE PROBLEM (CJT v. 7.1, WP 3.9.x)
After an import of database to a new location the CJT plugin shows no code blocks.

THE SOLUTION
After migration we should execute the following SQL command:
UPDATE ‘wp_cjtoolbox_blocks’ SET ‘parent’=NULL;
UPDATE ‘wp_cjtoolbox_blocks’ SET ‘backupId’=NULL WHERE ‘backupId’=’0’;

Finally we can see all our precious blocks of code. 🙂

Maybe the method described above will be useful to somebody.

Kind regards.
Sylwia

Hi Damian,

I have got no access to “CJT Pro Support Forum”.
I got msg: “This forum is restricted to buyers”.
Has developer (I mean a CJT Dev buyer) no access to “CJT Pro Support Forum”? It would not make much sense. 🙂

Kind regards
Sylwia

Hi Damian,

Is there any way to export and import all the snippets of code at once?

BTW: thank you for your plugin. I love it.

Kind regards.
Sylwia

Hi!
I tried to download CJT script packages but it redirects to another domain and my user details don’t let me login. Should I open an account there too?

Dear Sir/madam,

I installed the CJT on my WordPress before purchase the license. What should I after I purchase the license and remove the message “Like CSS & JS Toolbox Free? Upgrade CJT-Free” on top-right of the screen?

Best regards,

Kelvin.

Hi,

CJT tool box on my site has been disappeared, and just a blank page there, and right before that I had upgraded WP version to 3.9.1. I have no idea if that was the cause for the current blank issue. But anyway, I just downgraded to 3.9, but still the same. Please help me, for I really need CJT plugin for building my website.

Best regards,
Taka

Hi Damian,

Is it possible to assign a block to all post inside 1 specific CPT?

Thanks,
Antonio

Acquired, installed and activated with a license key my css & javascript toollbox dev, but when editing the page in the visual editor does not appear the ‘Insert CJT Block Shortcode’ button.
How do I appear in the visual editor (Insert CJT Block Shortcode) button?

Hello,
Since installing version 3.9 of WordPress, it is impossible to create a block
cordially

Hi Damian,

There is a strange warning after I upgrade WordPress from 3.8.1 to 3.9. After upgrading to 3.9, I got a warning “Warning: mysql_real_escape_string() expects parameter 2 to be resource, object given in C:\xampp\htdocs\rv\wp-content\plugins\css-javascript-toolbox\framework\db\mysql\queue-driver.inc.php on line 133”, on those pages that uses CJT code blocks.

I am developing locally on my computer.
XAMPP: v3.2.1
WordPress: 3.9
CJT: v7.0

Once I create a new code block and try to save it, the code disappears. How can I save the code without it disappearing?

Hello,

I have the Dev version of of CJT and I am installing it on a new installation of WP. The installation is vanilla 3.8.2 and following the instructions to activate the license. I check the license key and the plugin installed verifies that it is valid, but it won’t let me activate it from within the plugin. The plugin says that it must be activated from your site.

So I logged in and tried to add the domain through the manage sites area for view license. I put in the domain that the has the plugin installed and click add site. The browser bar turns showing a submission but your site refreshes the page and no entry was added.

Please advise.

Hello, I’m getting an error when I’m creating a code block. The dialog box stays up where I put in the name when I click the create button, and TypeError: this.form.serializeObject is not a function appears in the console. Any thoughts?
Thanks,
Allen

I want to individually style the posts on a category page. So far I see i can apply a block to a category or a single. Can I assign a block to a tag?

Hi,

I have had CJT for a while now but not had much time to really look at what it does.

It is all installed now on a local test site and I have downloaded the various scripts from your site.

However, I cannot get them to work.

The scripts are activated.

I have both the Page and URL in place.

I have checked for trailing slashes and removed.

I must be doing something wrong – but I have no idea what exactly.

Any help would be greatly appreciated.

Thank you

James

Hello,

Just to say that I discover your plugin 7 days ago and I just bought it yesterday. I’ve started playing with it and it is great to validate forms or add custom code to wordpress themes (instead of hacking functions.php).

I have a felling you are “one man show” but I really hope you go ahead with this because it is an unique tool and very useful both for non-programmers (like me) and developers.

In future updates you could even create an addon that could export a wordpress plugin transforming this tool into a product creation tool. AMAZING STUFF!

I bought Dev License right away to be an early adopter but wasn’t expecting paying in Australian Dolars… Is that on purpose or a “bad” payment configuration? 😉

best regards,
Antonio Almeida

I do not know why?
I updated CJTPro 6.3.1 to 6.3.2, on network administrator.
CJTPro seems to have been updated, but update nag still displayed…

So, It appears as this (Actually it was displayed in Japanese):
>CSS & JavaScript Toolbox
>Current version is 6.3.2. It will update to 6.3.2.

It does not disappear when I run update…
But CJTPro works well.

So creepy…

Is there a best fix way? or Should I wait for any update?

When attempting to upload the zip file for FooTables and a few other jquery files, I receive the error message String could not be parsed as xml.

I’m working from localhost.

Any suggestions?

Thanks.

I can’t access the tiny arrows (the pager) on the bottom right of the assign to page browser in the admin. The next panel overlays it and it’s not selectable. Even moving it to the bottom it will not activate and highlight. Any ideas?

Has anybody had problems running this script in the Avada theme from Codecanyon?

Hi there,

I’ve retried installing the pro version of CJT a few times (the free version worked fine), and the install process gets stuck on the “Add WordPress built-in scripts and styles as CJT Templates so it can be used throught Templates Lookup form” step. The earlier steps occur without issue and the process attempts to resume from the WOrdpress scripts step each time. I’m getting one of two unhandled exceptions:

Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 40 bytes) in /home/content/13/12077913/html/cryptocoin/wp-content/plugins/css-javascript-toolbox/framework/events/wordpress.class.php on line 57

Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 20 bytes) in /home/content/13/12077913/html/cryptocoin/wp-content/plugins/css-javascript-toolbox/framework/events/events.class.php on line 140

I’m on shared hosting (godaddy) so I can’t up my memory_limit in php.ini or .htaccess (I tried…).

I’m not running Bulletproof Security either.

Any fix for this one?

Hello,
I was wondering if it is possible to insert javascript to display something at the bottom of the header. So far I have only been able to display something at the very top of the header which is at the very top of my page?
Thank you.

Hi,

LOVE this plugin!!!

Probably a stupid question, but is there a way to simply tell a code block to apply to the whole site? Or do you have to select pages manually?

After I’m done uploading and installing, it then prompts me to run the setup for CJT. It get’s stuck on the creating database tables and just spins forever. Here’s a screenshot: http://screencast.com/t/rH9Lccjhcs78

Any ideas? Bulletproof security was running but I deactivated it. Thanks.

Hi,

Pardon my ignorance, but I received an email telling me about the shortcode forms and using the latest version of CJT, but when I login I do not know where to go to download either the new shortcode form or the updated CJT version.

Can you point me in the right direction please?

Thanks for your help.

Hi there,

I use CJT all the time and love it. I love it so much I just bought the pro version! Anyway, wondering about being able to upload a master file that would create the code blocks and put the scripts inside for me? Right now, every WordPress site I setup, I install CJT and then have to create 5 blocks manually and copy and paste my scripts from a notepad file. Wondering if there is an easier faster way when setting up multiple WordPress sites. All of my sites use the same set of scripts. Thanks.

David Farr

Hi there,

Using CJT, very happy indeed. Question though. It seems I can not run the shortcode in the text widget. Any thoughts? I’ve tried making it site-wide, specific page, specific url… nada.

Thoughts?

BJ

Hi there and welcome to the CSS & JavaScript Toolbox support forum.

Please post your support questions, feature ideas or general questions in a respectful manner.

Enjoy your stay!!!

Attempted to activate with pro code from purchase.

1. Checked code and received: The ckeck operation detects that the provided key is a valid key! The license key need to be activated from the CJT Website.

2: Activated code and received: Could not activate the provided license key!

Suggestions?

BJ

I want to prevent certain scripts from loading only on a mobile device, desktop and tablets are fine, but not mobile.

What code can I use to specify which devices the script will load on?

My site is responsive and knows when to show the mobile menu as opposed to the mega menu, so how do I do something similar here?

Symptoms:
– installation does not progress past the first step, and seems to be in an endless loop.
– cannot create new blocks, either clicking New Code Block button returns Forbidden 404 error OR if you do get the Create New Code Block popup, clicking CREATE does not do anything.
– Various functions do not do anything.
Cause:
AJAX calls are getting blocked by .htaccess rules created by the BulletProof Security plugin
The FIX:
– go into the BulletProof Security dashboard by clicking BPS Security
– go to the Custom Code tag
– scroll to the last text-box at the bottom with the title that says:
‘CUSTOM CODE WPADMIN PLUGIN FIXES: Add ONLY WPADMIN personal plugin fixes code here’
– paste this bypass script inside the text-box:

RewriteCond %{REQUEST_URI} (admin-ajax\.php) [NC]
RewriteRule . - [S=2]

– save this script by clicking the ‘Save wp-admin Custom Code’ button
– click the ‘Security Modes’ tab
– rebuild the .htaccess files by clicking the blue buttons that says: ‘Create secure.htaccess File’
– Look under the title ‘Activate Security Modes’ where it says:
‘Activate Website wp-admin Folder .htaccess Security Mode’
and click the radio button ‘BulletProof Mode’ and then click the blue ‘Activate’ button
– you should now be able to refresh the CJT setup or dashboard page